开发工具 mvim youcompleteme 出错

betterthornbird · 2014年06月08日 · 最后由 liwink 回复于 2016年01月09日 · 6080 次阅读

近两天在倒腾 vim 配置,将 vim/vi 命令 alias 成了 mvim.

目前每次运行 vim 都会出错

ycm_client_support.[so|pyd|dll] and ycm_core.[so|pyd|dll] not detected; you need to compile YCM before using it. Read the docs!

然后目前 mvim 的信息是:

$ vim --version
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled May 29 2014 14:43:15)
MacOS X (unix) version
Included patches: 1-258
Compiled by Homebrew
Huge version with MacVim GUI.  Features included (+) or not (-):
+acl             +file_in_path    +mouse_sgr       +tag_binary
+arabic          +find_in_path    -mouse_sysmouse  +tag_old_static
+autocmd         +float           +mouse_urxvt     -tag_any_white
+balloon_eval    +folding         +mouse_xterm     +tcl
+browse          -footer          +multi_byte      +terminfo
++builtin_terms  +fork()          +multi_lang      +termresponse
+byte_offset     +fullscreen      -mzscheme        +textobjects
+cindent         -gettext         +netbeans_intg   +title
+clientserver    -hangul_input    +odbeditor       +toolbar
+clipboard       +iconv           +path_extra      +transparency
+cmdline_compl   +insert_expand   +perl            +user_commands
+cmdline_hist    +jumplist        +persistent_undo +vertsplit
+cmdline_info    +keymap          +postscript      +virtualedit
+comments        +langmap         +printer         +visual
+conceal         +libcall         +profile         +visualextra
+cryptv          +linebreak       +python          +viminfo
+cscope          +lispindent      -python3         +vreplace
+cursorbind      +listcmds        +quickfix        +wildignore
+cursorshape     +localmap        +reltime         +wildmenu
+dialog_con_gui  -lua             +rightleft       +windows
+diff            +menu            +ruby            +writebackup
+digraphs        +mksession       +scrollbind      -X11
+dnd             +modify_fname    +signs           -xfontset
-ebcdic          +mouse           +smartindent     +xim
+emacs_tags      +mouseshape      -sniff           -xsmp
+eval            +mouse_dec       +startuptime     -xterm_clipboard
+ex_extra        -mouse_gpm       +statusline      -xterm_save
+extra_search    -mouse_jsbterm   -sun_workshop    -xpm
+farsi           +mouse_netterm   +syntax

里面是 +python -python3

搜索了下 youcompleteme 是只需要有 python 支持,不知道这里的配置是否满足条件,如果不满足,该怎么解决?

https://github.com/Valloric/YouCompleteMe#mac-os-x-super-quick-installation YCM 插件需要编译两个辅助的链接库,你可以参照上面的链接编译一下。

#1 楼 @edgar_wang_cn 谢咯, cd bundle/YouCompleteMe && ./install.sh --clang-completer 这样编译之后就好了

补充下,bundlevim 文件夹中。 在我的 Mac 中编译如下: cd ~/.vim/bundle/YouCompleteMe && ./install.sh --clang-completer

需要 登录 后方可回复, 如果你还没有账号请 注册新账号