新手问题 手贱,升级了到了 10.10 的 beta 系统然后就报错了。。。悲剧。。

suchiva · 2014年06月05日 · 最后由 jeff_duan 回复于 2014年06月20日 · 2645 次阅读
from /Library/Ruby/Gems/2.0.0/gems/sprockets-2.11.0/lib/sprockets.rb:62:in `require'
from /Library/Ruby/Gems/2.0.0/gems/sprockets-2.11.0/lib/sprockets.rb:62:in `<module:Sprockets>'
from /Library/Ruby/Gems/2.0.0/gems/sprockets-2.11.0/lib/sprockets.rb:3:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/sprockets-rails-2.0.1/lib/sprockets/railtie.rb:5:in `require'
from /Library/Ruby/Gems/2.0.0/gems/sprockets-rails-2.0.1/lib/sprockets/railtie.rb:5:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass/rails/railtie.rb:1:in `require'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass/rails/railtie.rb:1:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass/rails.rb:11:in `require'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass/rails.rb:11:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass-rails.rb:1:in `require'
from /Library/Ruby/Gems/2.0.0/gems/sass-rails-4.0.3/lib/sass-rails.rb:1:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:76:in `require'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:72:in `each'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:72:in `block in require'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:61:in `each'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler/runtime.rb:61:in `require'
from /Library/Ruby/Gems/2.0.0/gems/bundler-1.5.3/lib/bundler.rb:131:in `require'
from /Users/suchiva/Documents/Coder/rorProject/suchivaRor/config/application.rb:7:in `<top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/railties-4.0.3/lib/rails/commands.rb:74:in `require'
from /Library/Ruby/Gems/2.0.0/gems/railties-4.0.3/lib/rails/commands.rb:74:in `block in <top (required)>'
from /Library/Ruby/Gems/2.0.0/gems/railties-4.0.3/lib/rails/commands.rb:71:in `tap'
from /Library/Ruby/Gems/2.0.0/gems/railties-4.0.3/lib/rails/commands.rb:71:in `<top (required)>'
from bin/rails:4:in `require'

看提示是不是也写包要重新安装哈,还是什么原因?

提示信息不全,没法知道问题在哪里。 简单的处理方式,用 RVM 安装 Ruby

你这还有提示,我的直接卡在开机登陆页面,已经 2 天,再也没有反应了。

安装完 10.10 之后 ruby 版本变成了 2.0,之前装的 homebrew 用不了了,有没有高手指点下

#2 楼 @lanvige 听说是搜狗输入法出问题了

大概什么时候可以正式使用 10.10?

还好没升级。

我也升了,不是太坏,除了 PD,TextMate,Axure 等没法使用,其他正常。ruby 之前安装的是 2.1.1,没有任何变化,bundle 完了后即可正常工作。也没有别人说得什么输入法不能用的情况。只是在安装的最后 5 分钟卡了个把小时,最终还是过了。

mysql 出了点问题,安装完报权限没了,手工 chown -R use:staff 目录,然后跑起来了。

昨天 apple 在 apple store 推送了 P2,你试试更新 P2,看是否稳定。至少我这里感觉好很多,包括那个电源 BUG 也都修复了,只是很蛋疼的是几天间隔就推一个 1.5G 的文件,太无聊了。

你的日志贴全点,也许能便于大家帮你一起看看。

请问 Mysql 具体是怎么修复呢? 我的会报以下错误(升级前正常): mysql -u root ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

#8 楼 @5night 你这是 mysqld 都没启动起来,估计还是 #7 楼 @martin 描述的,mysql 的目录的权限变了,你查看下 mysql 启动报啥错,再解决.

@debugger 谢谢~ 已经恢复~

好恐怖,赶紧备份代码,我用的也是搜狗

我也升了 10.10, 确实会有些小问题, 有次还死机重启了... 无语.

需要 登录 后方可回复, 如果你还没有账号请 注册新账号