Rails bundle install 时出错

leveyzhu · 2012年03月12日 · 最后由 LeveyZhu 回复于 2012年03月12日 · 2868 次阅读

错误细节是这样的:

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/Users/Levey/.rvm/rubies/ruby-1.9.3-p125/bin/ruby extconf.rb extconf.rb:10: Use RbConfig instead of obsolete and deprecated Config. checking for libxml/parser.h... yes checking for libxslt/xslt.h... yes checking for libexslt/exslt.h... yes checking for iconv_open() in iconv.h... no checking for iconv_open() in -liconv... yes checking for xmlParseDoc() in -lxml2... yes checking for xsltParseStylesheetDoc() in -lxslt... yes checking for exsltFuncRegister() in -lexslt... yes checking for xmlHasFeature()... yes checking for xmlFirstElementChild()... yes checking for xmlRelaxNGSetParserStructuredErrors()... yes checking for xmlRelaxNGSetParserStructuredErrors()... yes checking for xmlRelaxNGSetValidStructuredErrors()... yes checking for xmlSchemaSetValidStructuredErrors()... yes checking for xmlSchemaSetParserStructuredErrors()... yes creating Makefile

make compiling html_document.c make: gcc-4.2.1: No such file or directory make: *** [html_document.o] Error 1

gcc 还没装

#1 楼 @Rei 奇怪,sudo 安装就好了。。。

需要 登录 后方可回复, 如果你还没有账号请 注册新账号