Gem [开源] 写了一个 FlatUI 的 gem-----flatui-rails-less,分享给大家

hanluner · 2013年11月02日 · 最后由 Ryan 回复于 2013年11月08日 · 4175 次阅读

由于自己在写一个东西,用到了扁平化设计的 Flat-UI,网上搜到了两个老外写的 gem,有很多问题,早已经脱离了最新的 Flat-ui,所以一怒之下,自己写了一个最新的 gem,比较简单,基于 Less.

flatui-rails-less

This is the Designmodo flat ui bootstrap in less.

Rubygems.org :https://rubygems.org/gems/flatui-rails-less

Github: https://github.com/hanluner/flatui-rails-less

Flat UI

Flat UI 是基于 Bootstrap 做的 Metro 化改造,由 Designmodo 提供。Flat UI 包含了很多 Bootstrap 提供的组件,但是外观更加漂亮。 官方地址:http://designmodo.github.io/Flat-UI/

欢迎交流

由于我技术比较拙劣,欢迎大家多提提意见,后续我还会大胆开源自己写的东西。

nice 那几个包确实问题各种有

请教一个问题,flat-ui 中怎么通过 js 去 triger select 事件。我的表单中 select 全部被它修改了。。

#2 楼 @small_fish__ 你指的是去除它的 select 事件,用你自己的? 那你得自己定制了,可以在 js 文件里最后面引用你自己的定义。默认是全集成加载的。

#1 楼 @kevinzhow 是,弄得很痛苦,他们早已经不更新了,连一个.navbar-inverse 的 navbar 都有。

赞 谢 LZ 分享,好人一生平安

不是去除,是通过 js 去模拟他的 select 事件,,

#6 楼 @small_fish__ 你是指什么事件?click 之类的事件不是自己写的吗?

#5 楼 @zhbinx 客气,帮忙看看有没有什么问题。提出来交流。

#1 楼 @kevinzhow #5 楼 @zhbinx #6 楼 @small_fish__
修改了一个默认引入 bootstrap 的问题,如果有需要,可以更新下。最新版本 1.3

支持 IE8 的吗

#11 楼 @yeyong14 官方提供包兼容 IE6-8,当然某些显示效果肯定不如 IE9 以上了。

赞,好漂亮!

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册