Gem gem install jekyll error

ssqq · 2013年08月13日 · 最后由 Perry 回复于 2013年08月13日 · 3533 次阅读

Windows 平台 cmd > gem install jekyll

ERROR: Error installing jekyll: The 'fast-stemmer' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit from 'http://rubyinstaller.org/downloads' and follow the instructions at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'

难道 Ruby 安装后,使用 Gem 还需要第三方组件?C 编译环境?

Requirements

Installing Jekyll is easy and straight-forward, but there are a few requirements you’ll need to make sure your system has before you start.

  • Ruby
  • RubyGems
  • Linux, Unix, or Mac OS X

Ruby 的世界里,Windows 是二等公民。开虚拟机吧。

ruby 从来没有说过 windows 是二等公民,而是某些 gem 的原因造成的,比如这种没好好写依赖了系统底层的东西的玩意

#2 楼 @ywjno 当然没说过.. tg 也没说过体制外的人是二等公民吧。现状就是这样,管你是什么原因造成的,有些东西 windows 下面就是不能用,那不就是二等了。

当然据我简单搜索,楼主这个 gem 在 windows 下面貌似是能折腾过去的。楼主不妨自己也搜一下。

需要 C 编译环境,提示写的很清楚啊。。

#3 楼 @blacktulip 二等公民至少也是公民,tg。。。

#3 楼 @blacktulip 我倒是知道有个 gem 在 mac 下需要你装 homebrew,不装就装不了,那按照这个理论不就是说没装 homebrew 的 mac 都是二等了

而且按照某个东西能不能用来作为判断的话,非 win 下的机器连 win32olewin32api这些 ruby 自带 的东东也用不了,是不是也可以说非 win 的机器都是二等呢?

Running Jekyll on Windows

It is possible to get Jekyll running on Windows, but the official documentation does not support installation on Windows platforms.

http://www.madhur.co.in/blog/2011/09/01/runningjekyllwindows.html

需要 登录 后方可回复, 如果你还没有账号请 注册新账号