反馈 ruby.taobao.org 镜像里没有 nokogiri

azhao · 2012年02月02日 · 最后由 gclsoft 回复于 2013年11月22日 · 4155 次阅读

$ gem install nokogiri ERROR: Could not find a valid gem 'nokogiri' (>= 0) in any repository ERROR: Possible alternatives: nokogiri

换回官方后没有问题

怎么有的 gem 没有被同步吗?

jason-imac ~ » gem source
*** CURRENT SOURCES ***

http://ruby.taobao.org
jason-imac ~ » gem search -r nokogiri             

*** REMOTE GEMS ***

backupify-rsolr-nokogiri (0.12.1.1)
glebm-nokogiri (1.4.2.1)
jwagener-nokogiri (1.4.1)
nokogiri (1.5.0 ruby java x86-mingw32 x86-mswin32-60, 1.4.4.1 x86-mswin32)
nokogiri-diff (0.1.0)
nokogiri-happymapper (0.3.6)
nokogiri-maglev- (1.5.0.1)
nokogiri-maven (1.5.0 java)
nokogiri-plist (0.5.0)
nokogiri-pretty (0.1.0)
revo-nokogiri (1.4.1 java)
rsolr-nokogiri (0.0.0)
rubyjedi-nokogiri_java (1.4.0.20100513161003 java)
sax-machine-nokogiri-1.4.4-safe (0.0.15)
superfeedr-nokogiri (1.4.0.20091116183308)

有的啊

[weiz@~/dev/ruby-china]$ gem sources *** CURRENT SOURCES ***

http://ruby.taobao.org/ [weiz@~/dev/ruby-china]$ gem search -r nokogiri

*** REMOTE GEMS ***

backupify-rsolr-nokogiri (0.12.1.1) glebm-nokogiri (1.4.2.1) jwagener-nokogiri (1.4.1) nokogiri (1.5.0 ruby java x86-mingw32 x86-mswin32-60, 1.4.4.1 x86-mswin32) nokogiri-diff (0.1.0) nokogiri-happymapper (0.3.6) nokogiri-maglev- (1.5.0.1) nokogiri-maven (1.5.0 java) nokogiri-plist (0.5.0) nokogiri-pretty (0.1.0) revo-nokogiri (1.4.1 java) rsolr-nokogiri (0.0.0) rubyjedi-nokogiri_java (1.4.0.20100513161003 java) sax-machine-nokogiri-1.4.4-safe (0.0.15) superfeedr-nokogiri (1.4.0.20091116183308) [weiz@~/dev/ruby-china]$ gem install nokogiri ERROR: Could not find a valid gem 'nokogiri' (>= 0) in any repository ERROR: Possible alternatives: nokogiri

我也搜索到,但是安装的时候就不成。好像装别的一些也不行,我在试其它的 gem install rails -v=3.1.3 好像就不成

好像是我这里的问题,现在 rubygems 上的也有问题了。。。。

有时候是网络问题,多试下。

公司又把淘宝给封了,冤冤相报何时了~

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册