新手问题 想更新 Bootstrap 的版本 (在线等)

chongfai13 · 2019年10月29日 · 最后由 chongfai13-github 回复于 2019年11月12日 · 238 次阅读

之前接手的时候这个项目是用 Bootstrap 4.1.1, 现在想更新到 4.3.1 并上传到伺服器

伺服器的 vendor > bundle > ruby> 2.5.0 > gems > 里面已经有 bootstrap-4.1.3, 小弟想更新这个到最新版本

此贴已暂时被屏蔽!

以下几种情况的帖子可能会被屏蔽:

  1. 标题/正文描述不清不楚;
  2. 无意义的发帖;
  3. 存在广告嫌疑;
  4. 招聘信息描述不清楚,未按照招聘节点的要求发帖,或职位信息不符合社区用户群需求;
  5. 新注册的帐号发布产品推广贴是不允许的哦,付出和回报是相等的,当然如果你的产品确实非常有意思,或是和 Ruby 有关的东西,是不会进入这个栏目的。
  6. 太过弱的提问会被直接转移到此节点,请在提问前多尝试,多搜索;
  7. 理论上,不允许发布 QQ 群、微信群之类讨论群。

如果你发现你的帖子被屏蔽,请自我检查反省,并修改帖子内容。


招聘贴被屏蔽原因

警告: 以后招聘贴不符合要求,直接屏蔽,管理员不再回复,如认真阅读,继续新发同样格式的贴,将会被禁用账号!

  • 排版请按 Ruby China 的 Markdown 格式要求,具体请认真阅读: 排版指导,并参考 这篇招聘 的排版;
  • 招聘内容过少,缺少公司介绍,产品介绍,职位介绍,或待遇,工作地,联系方式等必要信息;
  • 重复发帖(一家公司每月限制只能发一次招聘);
  • 专业不对口(个别不对口,但有特点的,我们会放过);

如果你有时间,请阅读 招聘栏目详细说明


学会如何合理提问,请阅读:https://ruby-china.org/topics/24325

当你修改好以后,可以回帖 @huacnlee@Rei@lgn21st 任何一人,我们将会审核,通过以后才可恢复到其他节点。

注!多次发现广告嫌疑的帐号,将会被禁用帐号。

共收到 3 条回复

看起来你需要学的东西挺多的。

项目需要在开发环境执行 bundle update 将 Gemfile.lock 里面的 bootstrap 更新到新版本,然后再发布。

或者你可以试试在服务器上执行 bundle update bootstrap,或者在项目文件夹把 Gemfile 里面的 gem "bootstrap" 的版本强制指定到特定版本:

Gemfile:

gem "bootstrap", "~> 4.1.3"

然后执行 bundle update

然后,你需要重启 Rails 应用服务器(我不知道用的啥,只能讲到这里了)


以上如果你能看懂应该很容易解决,如果你看不懂,我帮不了你了。 如果还是搞不定,你可以尝试找个懂的同事(比如之前部署的人)来解决,我就只能帮到这里了。

上面 huacnlee 说的挺好。不过 Gemfile 那里修改版本号后,执行 bundle install 就好。记得之前 bundle update 会去更新 Gemfile 里所有的 gem 到符合条件的最新版本,如果你只是想更新一个 gem 应该 install 就好。

huacnlee 屏蔽了此话题:提问长期置之不理,不跟进 10月30日 10:05

谢谢大大的帮助

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册