新手问题 (解决!) 大神求助!!!! Ruby 安装到 configuring 报错

JXwilliamJi · 发布于 2017年07月17日 · 最后由 JXwilliamJi 回复于 2017年07月20日 · 317 次阅读
96

使用的是mac ! 由于安装最新的Ruby on Rails 一致错误,找不到sqlite3 等一系列的gem ,我打算重新安装ruby。 然后我就把.rvm 删除了,重新安装rvm,然后安装ruby ,但是报了下面的错误,请大神帮忙!!跪谢!

还有我意识到是不是配置文件冲突了,但是我不知道配置文件到哪里设置,请指导!

共收到 16 条回复
4215

没有c编译器。安装苹果的开发包Xcode。

96
4215chenge 回复

你好,xcode 我一直都有安装,是不是要重装下

4215

据说还要安装这个: Command Line Tools。 你可以运行下cc,看有没有?

96
4215chenge 回复

Command Line Tools 也是有的,这就是个命令行编译运行打包OC代码的工具

4215

我看错了,是compiled无法运行,以前没见过。

4215

参考下这个看,似乎跟你的很类似。

sudo xcode-select -switch /Applications/Xcode-beta.app/Contents/Developer

https://stackoverflow.com/questions/30872048/brew-install-ruby-build-fails-with-cannot-run-c-compiled-programs

1107

sudo xcode-select --install

96
1107jasl 回复

说是这个原因,我装了好像也不行,我再试试

4215
32JXwilliamJi 回复

网上说的这个行,看行不? xcode-select --install, after, rvm get stable。两个命令。

96
4215chenge 回复

嗯,我试试

96
4215chenge 回复

感谢!

96

最后和大家说明下,我重装了RVM ,Command Line Tools以及HomeBrew,打算指定编译器版本安装ruby,环境重新载入,最后使用新的版本管理工具 https://ruby-china.org/wiki/rbenv-guide ,都不行!!!但是经过这一番折腾,我打算重启重装电脑了,嫌麻烦,再试一次!!然后就好了.... 下次有问题就重启电脑!!

775

下次用docker吧

1107
32JXwilliamJi 回复

你悟到了解决问题的真谛... 所以说还是要自己多琢磨

96
1107jasl 回复

果然还是很费时间的

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册