Rails 请问大家, rake db:migrate 时 报 iconv.so 错

ghn645568344 · 发布于 2017年06月05日 · 127 次阅读
16225

RT ruby 2.1.4 运行

rake db:migrate

时,报

rake aborted!
LoadError: incompatible library version - /home/haonan/.rvm/gems/ruby-2.1.4/gems/iconv-1.0.4/lib/iconv/iconv.so
/home/haonan/.rvm/gems/ruby-2.1.4/gems/iconv-1.0.4/lib/iconv.rb:1:in `require'
/home/haonan/.rvm/gems/ruby-2.1.4/gems/iconv-1.0.4/lib/iconv.rb:1:in `<top (required)>'
/home/haonan/文档/qianbao/config/application.rb:7:in `<top (required)>'
/home/haonan/文档/qianbao/Rakefile:4:in `<top (required)>'
/home/haonan/.rvm/gems/ruby-2.1.4/gems/rake-12.0.0/exe/rake:27:in `<top (required)>'
(See full trace by running task with --trace)

纠结一下午了,请问大神们怎么解决🙏

共收到 0 条回复
16225 ghn645568344 关闭了讨论 06月05日 17:27
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册