Ruby watir-webdriver 安装后,打开浏览器正常,然后再操作就报错了

1289207394 · 发布于 2017年06月04日 · 最后由 1289207394 回复于 2017年06月06日 · 175 次阅读
20825

脚本内容: require 'watir-webdriver' #打开浏览器 b = Watir::Browser.new :chrome b.goto('https://www.baidu.com') #找到输入框 b.text_field(:id,'kw').set('watir-webdriver') #点击一下百度搜索按钮 b.button(:id,'su').click()

注:执行之后,能看到浏览器打开,然后就报错了

共收到 3 条回复
10547

这玩意对浏览器版本要求极其高

16895

之前一段时间搞Capyabra,试过很多驱动PoltergeistSeleniumWebkit,最后 我的建议还是用selenium-webdriver

20825

正在学selenium2 ,谢谢哈

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册