Ruby 圣诞礼物:Ruby 2.4.0 Released

sticnarf · 发布于 2016年12月25日 · 最后由 kevin_jj 回复于 2016年12月31日 · 1564 次阅读
24965
共收到 12 条回复
3
lgn21st · #1 · 2016年12月25日 1 个赞

果然不负众望啊,每年圣诞节发个大版本,升~

24144
rubyfan1 · #2 · 2016年12月25日

不错不错

2575
darkbaby123 · #3 · 2016年12月25日

每年圣诞有惊喜

26232
samport · #4 · 2016年12月25日

rails 5能用吗?

3
lgn21st · #5 · 2016年12月25日 1 个赞

#4楼 @samport 亲测能用,Rails 5.0.1 上用没有问题,就是要无视下面的 warning

warning: constant ::Fixnum is deprecated
warning: constant ::Bignum is deprecated
96
nong · #6 · 2016年12月26日

有些Gem不兼容, 比如binding_of_callers, 没发现有什么升级的必要

775
nouse · #7 · 2016年12月26日

和ActiveSupport 2.3不兼容

12700
kevin_jj · #8 · 2016年12月26日 1 个赞

Ruby 2.4 is about 9% faster than 2.3.3. Memory consumption is also reduced by about 10%.

https://gettalong.org/blog/2016/ruby24-performance-looking-good.html

gem 'therubyracer' 不能兼容2.4

3
lgn21st · #9 · 2016年12月26日
756
psvr · #10 · 2016年12月27日

Christmas Driven Development.

2556
michael · #11 · 2016年12月30日

Support OpenSSL 1.1.0 (drop support for 0.9.7 or prior)!

12700
kevin_jj · #12 · 2016年12月31日

#9楼 @lgn21st 已替换,谢谢。

需要 登录 后方可回复, 如果你还没有账号请点击这里 注册