• 你这个问题也是有意思的.

    不知道有人安装成功的没?

    我去年用的deepin安装成功过,不过版本忘记了.

    为啥不把错误贴出来呢..

  • 楼主有个地方写法改下就好了了。

    @user39d data
    

    应该是

    this.props.handleNewRecord data
    # 如果把this换成@,就会变成  @user39d data了
    
  • #15楼 @lancegin 最后是和rails放在一起跑的。 之前是独立部署存在的问题。

  • <li class="js_model_name" data-id="<%= obj.id%>" >
    
    $(".js_model_name").on("click", function(){
        var id = $(this).data("id");
        console.log(id);
    })
    

    楼主这么试试呢?

  • #12楼 @mengqing 这个也是携带了的,刚又试了下,也不可以。 个人认为,和nginx配置没多大的关系,毕竟测试服务器是跑起来了。 不过星期六的时候,把他换成了和app一起跑,是可以跑起来了。

  • #10楼 @oyaxira 这个之前试过的,一样的错误。配置:

    upstream puma {
      server unix://path/appname-puma.sock;
    }
    
    server {
      ...
      location @puma {
        proxy_set_header   Upgrade $http_upgrade;
        proxy_set_header   Connection "Upgrade";
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_redirect off;
    
        proxy_pass http://puma;
    
      }
    }
    
  • #8楼 @hlcfan 谢谢呐。我貌似没有配置这些,直接绑定在puma上去跑了cable。

  • #6楼 @gyorou actioncable Consumer Configuration

    If you host your production server via https, you will need to use the wss scheme for your Action Cable server.

    我这里的是http协议。ws应该是正常的。

    WebSocket is closed before the connection is established.
    

    报错的意思大致是:

    In this code what it means is that ws.close() was called (by user code) before the connection was even given a chance to be established.

    大概的错误表示为: 在连接之前未关闭。

    有种说法是,测试环境和正式环境,都属于线上的环境,所以出现这种错误。对此不是很清楚。 我认为正式环境和测试环境是相对独立开的,在不同的服务器上,应该不是测试服务器导致的这个错误。

  • #3楼 @jun1st 恩,这里是特意改的。

  • #1楼 @gyorou

    1. 都在指定的一个域名下面,都是同源了吧。并且我也禁止了跨域的检查

      config.action_cable.disable_request_forgery_protection = true
      
    2. nginx的配置应该是没有问题的。同测试环境的配置是差不多的。